What’s Vulnerable › Vulnerabilities
CVE-2006-4519
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-07-10 · updated 2026-06-16
- Weakness: CWE-190
Description
Multiple integer overflows in the image loader plug-ins in GIMP before 2.2.16 allow user-assisted remote attackers to execute arbitrary code via crafted length values in (1) DICOM, (2) PNM, (3) PSD, (4) PSP, (5) Sun RAS, (6) XBM, and (7) XWD files.
Affected products
- GIMP: before 2.2.16 — fixed in 2.2.16
How to fix
Upgrade to a fixed version: GIMP 2.2.16. Check the vendor advisory for mitigations.
References
- http://bugzilla.gnome.org/show_bug.cgi?id=451379
- http://developer.gimp.org/NEWS-2.2
- http://issues.foresightlinux.org/browse/FL-457
- http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=551
- http://osvdb.org/42139
- http://osvdb.org/42140
- http://osvdb.org/42141
- http://osvdb.org/42142
- http://osvdb.org/42143
- http://osvdb.org/42144
- http://osvdb.org/42145
- http://secunia.com/advisories/26132
Get alerted when CVE-2006-4519 or the next vulnerability affects your stack