What’s Vulnerable › Vulnerabilities
CVE-2006-4980
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-10-10 · updated 2026-06-16
Description
Buffer overflow in the repr function in Python 2.3 through 2.6 before 20060822 allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via crafted wide character UTF-32/UCS-4 strings to certain scripts.
Affected products
- Python: before 2.3.6; from 2.4.0 before 2.4.4 — fixed in 2.3.6, 2.4.4
How to fix
Upgrade to a fixed version: Python 2.3.6, 2.4.4. Check the vendor advisory for mitigations.
References
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=391589
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=208162
- http://kb.vmware.com/KanisaPlatform/Publishing/882/5120103_f.SAL_Public.html
- http://secunia.com/advisories/22276
- http://secunia.com/advisories/22297
- http://secunia.com/advisories/22303
- http://secunia.com/advisories/22357
- http://secunia.com/advisories/22358
- http://secunia.com/advisories/22379
- http://secunia.com/advisories/22448
- http://secunia.com/advisories/22487
Get alerted when CVE-2006-4980 or the next vulnerability affects your stack