What’s Vulnerable › Vulnerabilities
CVE-2006-4997
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2006-10-10 · updated 2026-06-16
- Weakness: CWE-416
Description
The clip_mkip function in net/atm/clip.c of the ATM subsystem in Linux kernel allows remote attackers to cause a denial of service (panic) via unknown vectors that cause the ATM subsystem to access the memory of socket buffers after they are freed (freed pointer dereference).
Affected products
- Canonical Ubuntu Linux: 5.10, 6.06, 6.10
- Linux kernel: before 2.6.18 — fixed in 2.6.18
- Red Hat Enterprise Linux: 2.1, 3, 4
How to fix
Upgrade to a fixed version: Linux kernel 2.6.18. Check the vendor advisory for mitigations.
References
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=206265
- http://secunia.com/advisories/22253
- http://secunia.com/advisories/22279
- http://secunia.com/advisories/22292
- http://secunia.com/advisories/22497
- http://secunia.com/advisories/22762
- http://secunia.com/advisories/22945
- http://secunia.com/advisories/23064
- http://secunia.com/advisories/23370
- http://secunia.com/advisories/23384
- http://secunia.com/advisories/23395
- http://secunia.com/advisories/23474
Get alerted when CVE-2006-4997 or the next vulnerability affects your stack