What’s Vulnerable › Vulnerabilities
CVE-2006-5051
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 45.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-09-27 · updated 2026-06-16
- Weakness: CWE-415
Description
Signal handler race condition in OpenSSH before 4.4 allows remote attackers to cause a denial of service (crash), and possibly execute arbitrary code if GSSAPI authentication is enabled, via unspecified vectors that lead to a double-free.
Affected products
- macOS: before 10.3.9; from 10.4 through 10.4.8 — fixed in 10.3.9
- Apple Mac Os X Server: before 10.3.9; from 10.4 through 10.4.8 — fixed in 10.3.9
- Debian Linux: 3.1
- OpenSSH: through 4.4
How to fix
Upgrade to a fixed version: macOS 10.3.9; Apple Mac Os X Server 10.3.9. Check the vendor advisory for mitigations.
References
- http://docs.info.apple.com/article.html?artnum=305214
- http://lists.apple.com/archives/security-announce/2007/Mar/msg00002.html
- http://lists.freebsd.org/pipermail/freebsd-security/2006-October/004051.html
- http://marc.info/?l=openssh-unix-dev&m=115939141729160&w=2
- http://openssh.org/txt/release-4.4
- http://secunia.com/advisories/22158
- http://secunia.com/advisories/22173
- http://secunia.com/advisories/22183
- http://secunia.com/advisories/22196
- http://secunia.com/advisories/22208
Get alerted when CVE-2006-5051 or the next vulnerability affects your stack