What’s Vulnerable › Vulnerabilities
CVE-2006-5541
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-10-26 · updated 2026-06-16
Description
backend/parser/parse_coerce.c in PostgreSQL 7.4.1 through 7.4.14, 8.0.x before 8.0.9, and 8.1.x before 8.1.5 allows remote authenticated users to cause a denial of service (daemon crash) via a coercion of an unknown element to ANYARRAY.
Affected products
- PostgreSQL: from 7.4 before 7.4.14; from 8.0.0 before 8.0.9; from 8.1.0 before 8.1.5 — fixed in 7.4.14, 8.0.9, 8.1.5
How to fix
Upgrade to a fixed version: PostgreSQL 7.4.14, 8.0.9, 8.1.5. Check the vendor advisory for mitigations.
References
- http://projects.commandprompt.com/public/pgsql/changeset/26457
- http://secunia.com/advisories/22562
- http://secunia.com/advisories/22584
- http://secunia.com/advisories/22606
- http://secunia.com/advisories/22636
- http://secunia.com/advisories/23048
- http://secunia.com/advisories/23132
- http://secunia.com/advisories/24577
- http://securitytracker.com/id?1017115
- http://support.avaya.com/elmodocs2/security/ASA-2007-117.htm
- http://support.novell.com/techcenter/psdb/59650c03a8bc5ae310cd7898bd106ad2.html
- http://www.mandriva.com/security/advisories?name=MDKSA-2006:194
Get alerted when CVE-2006-5541 or the next vulnerability affects your stack