What’s Vulnerable › Vulnerabilities
CVE-2006-5752
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-06-27 · updated 2026-06-16
Description
Cross-site scripting (XSS) vulnerability in mod_status.c in the mod_status module in Apache HTTP Server (httpd), when ExtendedStatus is enabled and a public server-status page is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors involving charsets with browsers that perform "charset detection" when the content-type is not specified.
Affected products
- Apache HTTP Server: from 1.3.2 before 1.3.39; from 2.0.0 before 2.0.61; from 2.2.0 before 2.2.6 — fixed in 1.3.39, 2.0.61, 2.2.6
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Fedoraproject Fedora: 7
- RedHat Enterprise Linux Desktop: 3.0, 4.0, 5.0
- RedHat Enterprise Linux Eus: 4.5
- RedHat Enterprise Linux Server: 3.0, 4.0, 5.0
- RedHat Enterprise Linux Workstation: 3.0, 4.0, 5.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 1.3.39, 2.0.61, 2.2.6. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=186219
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=245112
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01178795
- http://httpd.apache.org/security/vulnerabilities_13.html
- http://httpd.apache.org/security/vulnerabilities_20.html
- http://httpd.apache.org/security/vulnerabilities_22.html
- http://lists.vmware.com/pipermail/security-announce/2009/000062.html
- http://osvdb.org/37052
- http://rhn.redhat.com/errata/RHSA-2007-0534.html
- http://rhn.redhat.com/errata/RHSA-2007-0556.html
- http://secunia.com/advisories/25827
- http://secunia.com/advisories/25830
Get alerted when CVE-2006-5752 or the next vulnerability affects your stack