What’s Vulnerable › Vulnerabilities

CVE-2006-6500

Description

Heap-based buffer overflow in Mozilla Firefox 2.x before 2.0.0.1, 1.5.x before 1.5.0.9, Thunderbird before 1.5.0.9, and SeaMonkey before 1.0.7 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code by setting the CSS cursor to certain images that cause an incorrect size calculation when converting to a Windows bitmap.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 1.5.0.9, 2.0.0.1; Mozilla Seamonkey 1.0.7; Mozilla Thunderbird 1.5.0.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2006-6500 or the next vulnerability affects your stack