What’s Vulnerable › Vulnerabilities
CVE-2006-6565
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 70.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2006-12-15 · updated 2026-06-16
- Weakness: CWE-476
Description
FileZilla Server before 0.9.22 allows remote attackers to cause a denial of service (crash) via a wildcard argument to the (1) LIST or (2) NLST commands, which results in a NULL pointer dereference, a different set of vectors than CVE-2006-6564. NOTE: CVE analysis suggests that the problem might be due to a malformed PORT command.
Affected products
- FileZilla Server: before 0.9.22 — fixed in 0.9.22
How to fix
Upgrade to a fixed version: FileZilla Server 0.9.22. Check the vendor advisory for mitigations.
References
- http://sourceforge.net/project/shownotes.php?release_id=470364&group_id=21558
- http://www.vupen.com/english/advisories/2006/4937
- https://exchange.xforce.ibmcloud.com/vulnerabilities/30853
- https://www.exploit-db.com/exploits/2914
- http://sourceforge.net/project/shownotes.php?release_id=470364&group_id=21558
- http://www.vupen.com/english/advisories/2006/4937
- https://exchange.xforce.ibmcloud.com/vulnerabilities/30853
- https://www.exploit-db.com/exploits/2914
Get alerted when CVE-2006-6565 or the next vulnerability affects your stack