What’s Vulnerable › Vulnerabilities
CVE-2006-7232
- Severity: low (CVSS 3.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2006-12-31 · updated 2026-06-16
- Weakness: CWE-89
Description
sql_select.cc in MySQL 5.0.x before 5.0.32 and 5.1.x before 5.1.14 allows remote authenticated users to cause a denial of service (crash) via an EXPLAIN SELECT FROM on the INFORMATION_SCHEMA table, as originally demonstrated using ORDER BY.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04, 7.10
- Mysql: from 5.0 before 5.0.32; from 5.1 before 5.1.14 — fixed in 5.0.32, 5.1.14
How to fix
Upgrade to a fixed version: Mysql 5.0.32, 5.1.14. Check the vendor advisory for mitigations.
References
- http://bugs.mysql.com/bug.php?id=22413
- http://dev.mysql.com/doc/refman/5.0/en/releasenotes-es-5-0-32.html
- http://dev.mysql.com/doc/refman/5.1/en/news-5-1-14.html
- http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00006.html
- http://secunia.com/advisories/29443
- http://secunia.com/advisories/30351
- http://secunia.com/advisories/31687
- http://www.redhat.com/support/errata/RHSA-2008-0364.html
- http://www.securityfocus.com/bid/28351
- http://www.ubuntu.com/usn/usn-588-1
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11720
- http://bugs.mysql.com/bug.php?id=22413
Get alerted when CVE-2006-7232 or the next vulnerability affects your stack