What’s Vulnerable › Vulnerabilities
CVE-2006-7254
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-10 · updated 2026-06-16
- Weakness: CWE-19
Description
The nscd daemon in the GNU C Library (glibc) before version 2.5 does not close incoming client sockets if they cannot be handled by the daemon, allowing local users to carry out a denial of service attack on the daemon.
Affected products
- GNU C Library (glibc): before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.5. Check the vendor advisory for mitigations.
References
- https://sourceware.org/bugzilla/show_bug.cgi?id=2498
- https://sourceware.org/bugzilla/show_bug.cgi?id=2498
Get alerted when CVE-2006-7254 or the next vulnerability affects your stack