What’s Vulnerable › Vulnerabilities
CVE-2007-0010
- Severity: low (CVSS 2.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-01-24 · updated 2026-06-16
Description
The GdkPixbufLoader function in GIMP ToolKit (GTK+) in GTK 2 (gtk2) before 2.4.13 allows context-dependent attackers to cause a denial of service (crash) via a malformed image file.
Affected products
- GNOME Gtk: before 2.4.13 — fixed in 2.4.13
How to fix
Upgrade to a fixed version: GNOME Gtk 2.4.13. Check the vendor advisory for mitigations.
References
- http://osvdb.org/31621
- http://secunia.com/advisories/23884
- http://secunia.com/advisories/23933
- http://secunia.com/advisories/23935
- http://secunia.com/advisories/23984
- http://secunia.com/advisories/24006
- http://secunia.com/advisories/24010
- http://secunia.com/advisories/24095
- http://securitytracker.com/id?1017552
- http://www.mandriva.com/security/advisories?name=MDKSA-2007:039
- http://www.novell.com/linux/security/advisories/2007_02_sr.html
- http://www.redhat.com/support/errata/RHSA-2007-0019.html
Get alerted when CVE-2007-0010 or the next vulnerability affects your stack