What’s Vulnerable › Vulnerabilities
CVE-2007-0455
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-01-30 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the gdImageStringFTEx function in gdft.c in GD Graphics Library 2.0.33 and earlier allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted string with a JIS encoded font.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Fedoraproject Fedora: 13, 14
- Gd Graphics Library Project Gd Graphics Library: through 2.0.33
- PHP: from 4.4.0 before 4.4.7 — fixed in 4.4.7
- RedHat Enterprise Linux Desktop: 3.0, 4.0
- RedHat Enterprise Linux Server: 3.0, 4.0
- RedHat Enterprise Linux Workstation: 3.0, 4.0
How to fix
Upgrade to a fixed version: PHP 4.4.7. Check the vendor advisory for mitigations.
References
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=224607
- http://fedoranews.org/cms/node/2631
- http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052848.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052854.html
- http://lists.rpath.com/pipermail/security-announce/2007-February/000145.html
- http://rhn.redhat.com/errata/RHSA-2007-0155.html
- http://secunia.com/advisories/23916
- http://secunia.com/advisories/24022
- http://secunia.com/advisories/24052
- http://secunia.com/advisories/24053
- http://secunia.com/advisories/24107
- http://secunia.com/advisories/24143
Get alerted when CVE-2007-0455 or the next vulnerability affects your stack