What’s Vulnerable › Vulnerabilities

CVE-2007-0555

Description

PostgreSQL 7.3 before 7.3.13, 7.4 before 7.4.16, 8.0 before 8.0.11, 8.1 before 8.1.7, and 8.2 before 8.2.2 allows attackers to disable certain checks for the data types of SQL function arguments, which allows remote authenticated users to cause a denial of service (server crash) and possibly access database content.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 7.3.18, 7.4.16, 8.0.11, 8.1.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2007-0555 or the next vulnerability affects your stack