What’s Vulnerable › Vulnerabilities
CVE-2007-0908
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-02-13 · updated 2026-06-16
- Weakness: CWE-20
Description
The WDDX deserializer in the wddx extension in PHP 5 before 5.2.1 and PHP 4 before 4.4.5 does not properly initialize the key_length variable for a numerical key, which allows context-dependent attackers to read stack memory via a wddxPacket element that contains a variable with a string name before a numerical variable.
Affected products
- Canonical Ubuntu Linux: 5.10, 6.06, 6.10
- PHP: from 4.0.0 before 4.4.5; from 5.0.0 before 5.2.1; 4.0, 4.0-beta_4_patch1, 4.0-beta1, 4.0-beta2, 4.0-beta3, 4.0-beta4 (+2) — fixed in 4.4.5, 5.2.1
How to fix
Upgrade to a fixed version: PHP 4.4.5, 5.2.1. Check the vendor advisory for mitigations.
References
- http://lists.suse.com/archive/suse-security-announce/2007-Mar/0003.html
- http://osvdb.org/32766
- http://rhn.redhat.com/errata/RHSA-2007-0089.html
- http://secunia.com/advisories/24089
- http://secunia.com/advisories/24195
- http://secunia.com/advisories/24217
- http://secunia.com/advisories/24236
- http://secunia.com/advisories/24248
- http://secunia.com/advisories/24284
- http://secunia.com/advisories/24295
- http://secunia.com/advisories/24322
Get alerted when CVE-2007-0908 or the next vulnerability affects your stack