What’s Vulnerable › Vulnerabilities
CVE-2007-0957
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-04-06 · updated 2026-06-16
- Weakness: CWE-787
Description
Stack-based buffer overflow in the krb5_klog_syslog function in the kadm5 library, as used by the Kerberos administration daemon (kadmind) and Key Distribution Center (KDC), in MIT krb5 before 1.6.1 allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via crafted arguments, possibly involving certain format string specifiers.
Affected products
- Canonical Ubuntu Linux: 5.10, 6.06, 6.10
- Debian Linux: 3.1, 4.0
- MIT Kerberos 5: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.6.1. Check the vendor advisory for mitigations.
References
- http://docs.info.apple.com/article.html?artnum=305391
- http://lists.apple.com/archives/Security-announce/2007/Apr/msg00001.html
- http://lists.suse.com/archive/suse-security-announce/2007-Apr/0001.html
- http://secunia.com/advisories/24706
- http://secunia.com/advisories/24735
- http://secunia.com/advisories/24736
- http://secunia.com/advisories/24740
- http://secunia.com/advisories/24750
- http://secunia.com/advisories/24757
- http://secunia.com/advisories/24785
- http://secunia.com/advisories/24786
Get alerted when CVE-2007-0957 or the next vulnerability affects your stack