What’s Vulnerable › Vulnerabilities
CVE-2007-0988
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-02-20 · updated 2026-06-16
- Weakness: CWE-119
Description
The zend_hash_init function in PHP 5 before 5.2.1 and PHP 4 before 4.4.5, when running on a 64-bit platform, allows context-dependent attackers to cause a denial of service (infinite loop) by unserializing certain integer expressions, which only cause 32-bit arguments to be used after the check for a negative value, as demonstrated by an "a:2147483649:{" argument.
Affected products
- Canonical Ubuntu Linux: 5.10, 6.06, 6.10
- PHP: from 4.0.0 before 4.4.5; from 5.0.0 before 5.2.1; 4.0, 4.0-beta_4_patch1, 4.0-beta1, 4.0-beta2, 4.0-beta3, 4.0-beta4 (+2) — fixed in 4.4.5, 5.2.1
How to fix
Upgrade to a fixed version: PHP 4.4.5, 5.2.1. Check the vendor advisory for mitigations.
References
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=228858
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01056506
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01086137
- http://osvdb.org/32762
- http://rhn.redhat.com/errata/RHSA-2007-0089.html
- http://secunia.com/advisories/24195
- http://secunia.com/advisories/24217
- http://secunia.com/advisories/24236
- http://secunia.com/advisories/24248
- http://secunia.com/advisories/24284
- http://secunia.com/advisories/24295
Get alerted when CVE-2007-0988 or the next vulnerability affects your stack