What’s Vulnerable › Vulnerabilities
CVE-2007-10003: The Hackers Diet Plugin HTTP POST Request ajax_blurb.php sql injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-29 · updated 2026-06-16
- Weakness: CWE-89
Description
A vulnerability, which was classified as critical, has been found in The Hackers Diet Plugin up to 0.9.6b on WordPress. This issue affects some unknown processing of the file ajax_blurb.php of the component HTTP POST Request Handler. The manipulation of the argument user leads to sql injection. The attack may be initiated remotely. Upgrading to version 0.9.7b is able to address this issue. The patch is named 7dd8acf7cd8442609840037121074425d363b694. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-243803.
Affected products
- The Hackers Diet Plugin: before 0.9.7b — fixed in 0.9.7b
How to fix
Upgrade to a fixed version: The Hackers Diet Plugin 0.9.7b. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/the-hackers-diet/commit/7dd8acf7cd8442609840037121074425d363b694
- https://github.com/wp-plugins/the-hackers-diet/releases/tag/0.9.7b
- https://vuldb.com/?ctiid.243803
- https://vuldb.com/?id.243803
- https://github.com/wp-plugins/the-hackers-diet/commit/7dd8acf7cd8442609840037121074425d363b694
- https://github.com/wp-plugins/the-hackers-diet/releases/tag/0.9.7b
- https://vuldb.com/?ctiid.243803
- https://vuldb.com/?id.243803
Get alerted when CVE-2007-10003 or the next vulnerability affects your stack