What’s Vulnerable › Vulnerabilities
CVE-2007-1216
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-04-06 · updated 2026-06-16
- Weakness: CWE-415
Description
Double free vulnerability in the GSS-API library (lib/gssapi/krb5/k5unseal.c), as used by the Kerberos administration daemon (kadmind) in MIT krb5 before 1.6.1, when used with the authentication method provided by the RPCSEC_GSS RPC library, allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via a message with an "an invalid direction encoding".
Affected products
- Canonical Ubuntu Linux: 5.10, 6.06, 6.10
- Debian Linux: 3.1, 4.0
- MIT Kerberos 5: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.6.1. Check the vendor advisory for mitigations.
References
- http://docs.info.apple.com/article.html?artnum=305391
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01056923
- http://lists.apple.com/archives/Security-announce/2007/Apr/msg00001.html
- http://lists.suse.com/archive/suse-security-announce/2007-Apr/0001.html
- http://secunia.com/advisories/24706
- http://secunia.com/advisories/24735
- http://secunia.com/advisories/24736
- http://secunia.com/advisories/24740
- http://secunia.com/advisories/24750
- http://secunia.com/advisories/24757
- http://secunia.com/advisories/24785
Get alerted when CVE-2007-1216 or the next vulnerability affects your stack