What’s Vulnerable › Vulnerabilities
CVE-2007-1285
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-03-06 · updated 2026-06-16
- Weakness: CWE-674
Description
The Zend Engine in PHP 4.x before 4.4.7, and 5.x before 5.2.2, allows remote attackers to cause a denial of service (stack exhaustion and PHP crash) via deeply nested arrays, which trigger deep recursion in the variable destruction routines.
Affected products
- Canonical Ubuntu Linux: 7.10
- Novell Suse Linux: 10.0, 10.1
- PHP: from 4.0.0 before 4.4.7; from 5.0.0 before 5.2.2 — fixed in 4.4.7, 5.2.2
- RedHat Enterprise Linux Desktop: 3.0, 4.0
- RedHat Enterprise Linux Server: 2.0, 3.0, 4.0
- RedHat Enterprise Linux Workstation: 2.0, 3.0, 4.0
- SUSE Linux Enterprise Server: 8, 10-sp1
How to fix
Upgrade to a fixed version: PHP 4.4.7, 5.2.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2007-07/msg00006.html
- http://rhn.redhat.com/errata/RHSA-2007-0154.html
- http://rhn.redhat.com/errata/RHSA-2007-0155.html
- http://rhn.redhat.com/errata/RHSA-2007-0163.html
- http://secunia.com/advisories/24909
- http://secunia.com/advisories/24910
- http://secunia.com/advisories/24924
- http://secunia.com/advisories/24941
- http://secunia.com/advisories/24945
- http://secunia.com/advisories/25445
- http://secunia.com/advisories/26048
- http://secunia.com/advisories/26642
Get alerted when CVE-2007-1285 or the next vulnerability affects your stack