What’s Vulnerable › Vulnerabilities
CVE-2007-1399
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-03-10 · updated 2026-06-16
Description
Stack-based buffer overflow in the zip:// URL wrapper in PECL ZIP 1.8.3 and earlier, as bundled with PHP 5.2.0 and 5.2.1, allows remote attackers to execute arbitrary code via a long zip:// URL, as demonstrated by actively triggering URL access from a remote PHP interpreter via avatar upload or blog pingback.
Affected products
- PHP: 5.2.0, 5.2.1
- Pierrejoye Php Zip: before 1.8.4 — fixed in 1.8.4
How to fix
Upgrade to a fixed version: Pierrejoye Php Zip 1.8.4. Check the vendor advisory for mitigations.
References
- http://lists.suse.com/archive/suse-security-announce/2007-Mar/0003.html
- http://secunia.com/advisories/24471
- http://secunia.com/advisories/24514
- http://secunia.com/advisories/25938
- http://www.debian.org/security/2007/dsa-1330
- http://www.osvdb.org/32782
- http://www.php-security.org/MOPB/MOPB-16-2007.html
- http://www.securityfocus.com/bid/22883
- http://www.vupen.com/english/advisories/2007/0898
- https://exchange.xforce.ibmcloud.com/vulnerabilities/32889
- http://lists.suse.com/archive/suse-security-announce/2007-Mar/0003.html
- http://secunia.com/advisories/24471
Get alerted when CVE-2007-1399 or the next vulnerability affects your stack