What’s Vulnerable › Vulnerabilities
CVE-2007-1701
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-03-27 · updated 2026-06-16
- Weakness: CWE-502
Description
PHP 4 before 4.4.5, and PHP 5 before 5.2.1, when register_globals is enabled, allows context-dependent attackers to execute arbitrary code via deserialization of session data, which overwrites arbitrary global variables, as demonstrated by calling session_decode on a string beginning with "_SESSION|s:39:".
Affected products
- PHP: from 4.0.0 before 4.4.5; from 5.0.0 before 5.2.1 — fixed in 4.4.5, 5.2.1
How to fix
Upgrade to a fixed version: PHP 4.4.5, 5.2.1. Check the vendor advisory for mitigations.
References
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01056506
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01086137
- http://secunia.com/advisories/25423
- http://secunia.com/advisories/25445
- http://secunia.com/advisories/25850
- http://security.gentoo.org/glsa/glsa-200705-19.xml
- http://www.php-security.org/MOPB/MOPB-31-2007.html
- http://www.securityfocus.com/bid/23120
- http://www.vupen.com/english/advisories/2007/1991
- http://www.vupen.com/english/advisories/2007/2374
- https://exchange.xforce.ibmcloud.com/vulnerabilities/33658
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11034
Get alerted when CVE-2007-1701 or the next vulnerability affects your stack