What’s Vulnerable › Vulnerabilities
CVE-2007-1864
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-05-09 · updated 2026-06-16
- Weakness: CWE-119
Description
Buffer overflow in the bundled libxmlrpc library in PHP before 4.4.7, and 5.x before 5.2.2, has unknown impact and remote attack vectors.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Debian Linux: 3.1, 4.0
- PHP: before 4.4.7; from 5.1.0 through 5.1.6; from 5.2.0 before 5.2.2 — fixed in 4.4.7, 5.2.2
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Workstation: 5.0
How to fix
Upgrade to a fixed version: PHP 4.4.7, 5.2.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2007-07/msg00006.html
- http://osvdb.org/34674
- http://secunia.com/advisories/25187
- http://secunia.com/advisories/25191
- http://secunia.com/advisories/25255
- http://secunia.com/advisories/25445
- http://secunia.com/advisories/25660
- http://secunia.com/advisories/25938
- http://secunia.com/advisories/25945
- http://secunia.com/advisories/26048
- http://secunia.com/advisories/26102
- http://secunia.com/advisories/27377
Get alerted when CVE-2007-1864 or the next vulnerability affects your stack