What’s Vulnerable › Vulnerabilities
CVE-2007-1887
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-04-06 · updated 2026-06-16
- Weakness: CWE-120
Description
Buffer overflow in the sqlite_decode_binary function in the bundled sqlite library in PHP 4 before 4.4.5 and PHP 5 before 5.2.1 allows context-dependent attackers to execute arbitrary code via an empty value of the in parameter, as demonstrated by calling the sqlite_udf_decode_binary function with a 0x01 character.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Debian Linux: 4.0
- PHP: from 4.0 before 4.4.5; from 5.0.0 before 5.2.3 — fixed in 4.4.5, 5.2.3
How to fix
Upgrade to a fixed version: PHP 4.4.5, 5.2.3. Check the vendor advisory for mitigations.
References
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01178795
- http://secunia.com/advisories/24909
- http://secunia.com/advisories/25057
- http://secunia.com/advisories/25062
- http://secunia.com/advisories/27037
- http://secunia.com/advisories/27102
- http://secunia.com/advisories/27110
- http://www.debian.org/security/2007/dsa-1283
- http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml
- http://www.mandriva.com/security/advisories?name=MDKSA-2007:088
- http://www.mandriva.com/security/advisories?name=MDKSA-2007:089
- http://www.php-security.org/MOPB/MOPB-41-2007.html
Get alerted when CVE-2007-1887 or the next vulnerability affects your stack