What’s Vulnerable › Vulnerabilities
CVE-2007-1923
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-04-10 · updated 2026-06-16
Description
(1) LedgerSMB and (2) DWS Systems SQL-Ledger implement access control lists by changing the set of URLs linked from menus, which allows remote attackers to access restricted functionality via direct requests. The LedgerSMB affected versions are before 1.3.0.
Affected products
- ledgersmb/ledgersmb: before 1.3.0 — fixed in 1.3.0
- Sql-Ledger: all versions
How to fix
Upgrade to a fixed version: ledgersmb/ledgersmb 1.3.0. Check the vendor advisory for mitigations.
References
- http://osvdb.org/38217
- http://osvdb.org/38218
- http://securityreason.com/securityalert/2552
- http://www.securityfocus.com/archive/1/464880/100/0/threaded
- http://www.securityfocus.com/bid/23352
- https://exchange.xforce.ibmcloud.com/vulnerabilities/33494
- https://github.com/ledgersmb/LedgerSMB/blob/master/Changelog
- http://osvdb.org/38217
- http://osvdb.org/38218
- http://securityreason.com/securityalert/2552
- http://www.securityfocus.com/archive/1/464880/100/0/threaded
- http://www.securityfocus.com/bid/23352
Get alerted when CVE-2007-1923 or the next vulnerability affects your stack