What’s Vulnerable › Vulnerabilities
CVE-2007-2138
- Severity: medium (CVSS 6.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-04-24 · updated 2026-06-16
- Weakness: CWE-264
Description
Untrusted search path vulnerability in PostgreSQL before 7.3.19, 7.4.x before 7.4.17, 8.0.x before 8.0.13, 8.1.x before 8.1.9, and 8.2.x before 8.2.4 allows remote authenticated users, when permitted to call a SECURITY DEFINER function, to gain the privileges of the function owner, related to "search_path settings."
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Debian Linux: 3.1, 4.0
- PostgreSQL: before 7.3.19; from 7.4 before 7.4.17; from 8.0 before 8.0.13; from 8.1 before 8.1.9; from 8.2 before 8.2.4 — fixed in 7.3.19, 7.4.17, 8.0.13, 8.1.9, 8.2.4
How to fix
Upgrade to a fixed version: PostgreSQL 7.3.19, 7.4.17, 8.0.13, 8.1.9. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2007-0336.html
- http://secunia.com/advisories/24989
- http://secunia.com/advisories/24999
- http://secunia.com/advisories/25005
- http://secunia.com/advisories/25019
- http://secunia.com/advisories/25037
- http://secunia.com/advisories/25058
- http://secunia.com/advisories/25184
- http://secunia.com/advisories/25238
- http://secunia.com/advisories/25334
- http://secunia.com/advisories/25717
- http://secunia.com/advisories/25720
Get alerted when CVE-2007-2138 or the next vulnerability affects your stack