What’s Vulnerable › Vulnerabilities

CVE-2007-2691

Description

MySQL before 4.1.23, 5.0.x before 5.0.42, and 5.1.x before 5.1.18 does not require the DROP privilege for RENAME TABLE statements, which allows remote authenticated users to rename arbitrary tables.

Affected products

How to fix

Upgrade to a fixed version: Mysql 5.0.42, 5.1.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2007-2691 or the next vulnerability affects your stack