What’s Vulnerable › Vulnerabilities
CVE-2007-3126
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-06-08 · updated 2026-06-16
Description
Gimp before 2.8.22 allows context-dependent attackers to cause a denial of service (crash) via an ICO file with an InfoHeader containing a Height of zero, a similar issue to CVE-2007-2237.
Affected products
- GIMP: before 2.8.22 — fixed in 2.8.22
How to fix
Upgrade to a fixed version: GIMP 2.8.22. Check the vendor advisory for mitigations.
References
- http://osvdb.org/43453
- http://www.securityfocus.com/archive/1/470751/100/0/threaded
- https://bugzilla.gnome.org/show_bug.cgi?id=778604
- https://exchange.xforce.ibmcloud.com/vulnerabilities/34789
- https://git.gnome.org/browse/gimp/commit/?id=323ecb73f7bf36788fb7066eb2d6678830cd5de7
- https://www.gimp.org/news/2017/05/11/gimp-2-8-22-released/
- http://osvdb.org/43453
- http://www.securityfocus.com/archive/1/470751/100/0/threaded
- https://bugzilla.gnome.org/show_bug.cgi?id=778604
- https://exchange.xforce.ibmcloud.com/vulnerabilities/34789
- https://git.gnome.org/browse/gimp/commit/?id=323ecb73f7bf36788fb7066eb2d6678830cd5de7
- https://www.gimp.org/news/2017/05/11/gimp-2-8-22-released/
Get alerted when CVE-2007-3126 or the next vulnerability affects your stack