What’s Vulnerable › Vulnerabilities
CVE-2007-3278
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-06-19 · updated 2026-06-16
- Weakness: CWE-264
Description
PostgreSQL 8.1 and probably later versions, when local trust authentication is enabled and the Database Link library (dblink) is installed, allows remote attackers to access arbitrary accounts and execute arbitrary SQL queries via a dblink host parameter that proxies the connection from 127.0.0.1.
Affected products
- Debian Linux: 3.1, 4.0
- PostgreSQL: from 7.3 before 7.3.21; from 7.4 before 7.4.19; from 8.0 before 8.0.15; from 8.1 before 8.1.11; from 8.2 before 8.2.6 — fixed in 7.3.21, 7.4.19, 8.0.15, 8.1.11, 8.2.6
How to fix
Upgrade to a fixed version: PostgreSQL 7.3.21, 7.4.19, 8.0.15, 8.1.11. Check the vendor advisory for mitigations.
References
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01420154
- http://osvdb.org/40899
- http://secunia.com/advisories/28376
- http://secunia.com/advisories/28437
- http://secunia.com/advisories/28438
- http://secunia.com/advisories/28445
- http://secunia.com/advisories/28454
- http://secunia.com/advisories/28477
- http://secunia.com/advisories/28479
- http://secunia.com/advisories/28679
- http://secunia.com/advisories/29638
- http://security.gentoo.org/glsa/glsa-200801-15.xml
Get alerted when CVE-2007-3278 or the next vulnerability affects your stack