What’s Vulnerable › Vulnerabilities
CVE-2007-3304
- Severity: medium (CVSS 4.7 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-06-20 · updated 2026-06-16
Description
Apache httpd 1.3.37, 2.0.59, and 2.2.4 with the Prefork MPM module, allows local users to cause a denial of service by modifying the worker_score and process_score arrays to reference an arbitrary process ID, which is sent a SIGUSR1 signal from the master process, aka "SIGUSR1 killer."
Affected products
- Apache HTTP Server: from 1.3.0 before 1.3.39; from 2.0.0 before 2.0.61; from 2.2.0 before 2.2.6 — fixed in 1.3.39, 2.0.61, 2.2.6
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Fedoraproject Fedora: 7
- RedHat Enterprise Linux Desktop: 5.0
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Workstation: 5.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 1.3.39, 2.0.61, 2.2.6. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=186219
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=245111
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01182588
- http://httpd.apache.org/security/vulnerabilities_13.html
- http://httpd.apache.org/security/vulnerabilities_20.html
- http://httpd.apache.org/security/vulnerabilities_22.html
- http://lists.vmware.com/pipermail/security-announce/2009/000062.html
- http://mail-archives.apache.org/mod_mbox/httpd-dev/200706.mbox/%3c20070629141032.GA15192%40redhat.com%3e
- http://marc.info/?l=apache-httpd-dev&m=118252946632447&w=2
- http://osvdb.org/38939
- http://rhn.redhat.com/errata/RHSA-2007-0556.html
Get alerted when CVE-2007-3304 or the next vulnerability affects your stack