What’s Vulnerable › Vulnerabilities
CVE-2007-3387
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-07-30 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the StreamPredictor::StreamPredictor function in xpdf 3.02, as used in (1) poppler before 0.5.91, (2) gpdf before 2.8.2, (3) kpdf, (4) kdegraphics, (5) CUPS, (6) PDFedit, and other products, might allow remote attackers to execute arbitrary code via a crafted PDF file that triggers a stack-based buffer overflow in the StreamPredictor::getNextLine function.
Affected products
- cups: through 1.3.11
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- Debian Linux: 3.1, 4.0
- poppler: before 0.5.91 — fixed in 0.5.91
- Gpdf Project Gpdf: before 2.8.2 — fixed in 2.8.2
- Xpdf: 3.02
How to fix
Upgrade to a fixed version: poppler 0.5.91; Gpdf Project Gpdf 2.8.2. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=187139
- http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248194
- http://osvdb.org/40127
- http://secunia.com/advisories/26188
- http://secunia.com/advisories/26251
- http://secunia.com/advisories/26254
- http://secunia.com/advisories/26255
- http://secunia.com/advisories/26257
- http://secunia.com/advisories/26278
- http://secunia.com/advisories/26281
Get alerted when CVE-2007-3387 or the next vulnerability affects your stack