What’s Vulnerable › Vulnerabilities
CVE-2007-3847
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-08-23 · updated 2026-06-16
- Weakness: CWE-125
Description
The date handling code in modules/proxy/proxy_util.c (mod_proxy) in Apache 2.3.0, when using a threaded MPM, allows remote origin servers to cause a denial of service (caching forward proxy process crash) via crafted date headers that trigger a buffer over-read.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.61; from 2.2.0 before 2.2.6 — fixed in 2.0.61, 2.2.6
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04, 7.10
- Fedoraproject Fedora: 7
- Fedoraproject Fedora Core: 6
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.61, 2.2.6. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=186219
- http://docs.info.apple.com/article.html?artnum=307562
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01182588
- http://httpd.apache.org/security/vulnerabilities_20.html
- http://httpd.apache.org/security/vulnerabilities_22.html
- http://lists.apple.com/archives/security-announce/2008//May/msg00001.html
- http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html
- http://lists.vmware.com/pipermail/security-announce/2009/000062.html
- http://marc.info/?l=apache-cvs&m=118592992309395&w=2
- http://marc.info/?l=apache-httpd-dev&m=118595556504202&w=2
- http://marc.info/?l=apache-httpd-dev&m=118595953217856&w=2
- http://secunia.com/advisories/26636
Get alerted when CVE-2007-3847 or the next vulnerability affects your stack