What’s Vulnerable › Vulnerabilities
CVE-2007-3998
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-09-04 · updated 2026-06-16
- Weakness: CWE-20
Description
The wordwrap function in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, does not properly use the breakcharlen variable, which allows remote attackers to cause a denial of service (divide-by-zero error and application crash, or infinite loop) via certain arguments, as demonstrated by a 'chr(0), 0, ""' argument set.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04, 7.10
- Debian Linux: 3.1, 4.0
- PHP: from 4.0.0 before 4.4.8; from 5.0.0 before 5.2.4 — fixed in 4.4.8, 5.2.4
How to fix
Upgrade to a fixed version: PHP 4.4.8, 5.2.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html
- http://rhn.redhat.com/errata/RHSA-2007-0889.html
- http://secunia.com/advisories/26642
- http://secunia.com/advisories/26822
- http://secunia.com/advisories/26838
- http://secunia.com/advisories/26871
- http://secunia.com/advisories/26895
- http://secunia.com/advisories/26930
- http://secunia.com/advisories/26967
- http://secunia.com/advisories/27102
- http://secunia.com/advisories/27377
- http://secunia.com/advisories/27545
Get alerted when CVE-2007-3998 or the next vulnerability affects your stack