What’s Vulnerable › Vulnerabilities
CVE-2007-4045
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-07-27 · updated 2026-06-16
Description
The CUPS service, as used in SUSE Linux before 20070720 and other Linux distributions, allows remote attackers to cause a denial of service via unspecified vectors related to an incomplete fix for CVE-2007-0720 that introduced a different denial of service problem in SSL negotiation.
Affected products
- cups: before 1.2.0 — fixed in 1.2.0
- Fedoraproject Fedora: 7
How to fix
Upgrade to a fixed version: cups 1.2.0. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=199195
- http://secunia.com/advisories/27577
- http://secunia.com/advisories/27615
- http://secunia.com/advisories/28113
- http://support.avaya.com/elmodocs2/security/ASA-2007-476.htm
- http://www.gentoo.org/security/en/glsa/glsa-200712-14.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2008:036
- http://www.novell.com/linux/security/advisories/2007_14_sr.html
- http://www.redhat.com/support/errata/RHSA-2007-1022.html
- http://www.redhat.com/support/errata/RHSA-2007-1023.html
- http://www.securityfocus.com/bid/26524
- https://bugzilla.redhat.com/show_bug.cgi?id=250161
Get alerted when CVE-2007-4045 or the next vulnerability affects your stack