What’s Vulnerable › Vulnerabilities
CVE-2007-4465
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 26.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-09-14 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in mod_autoindex.c in the Apache HTTP Server before 2.2.6, when the charset on a server-generated page is not defined, allows remote attackers to inject arbitrary web script or HTML via the P parameter using the UTF-7 charset. NOTE: it could be argued that this issue is due to a design limitation of browsers that attempt to perform automatic content type detection.
Affected products
- Apache HTTP Server: from 2.0.0 before 2.0.61; from 2.2.0 before 2.2.6 — fixed in 2.0.61, 2.2.6
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.61, 2.2.6. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=186219
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01539432
- http://lists.apple.com/archives/security-announce/2008//May/msg00001.html
- http://marc.info/?l=bugtraq&m=124654546101607&w=2
- http://marc.info/?l=bugtraq&m=125631037611762&w=2
- http://secunia.com/advisories/26842
- http://secunia.com/advisories/26952
- http://secunia.com/advisories/27563
- http://secunia.com/advisories/27732
- http://secunia.com/advisories/28467
- http://secunia.com/advisories/28471
- http://secunia.com/advisories/28607
Get alerted when CVE-2007-4465 or the next vulnerability affects your stack