What’s Vulnerable › Vulnerabilities
CVE-2007-4657
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-09-04 · updated 2026-06-16
- Weakness: CWE-119
Description
Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers to obtain sensitive information (memory contents) or cause a denial of service (thread crash) via a large len value to the (1) strspn or (2) strcspn function, which triggers an out-of-bounds read. NOTE: this affects different product versions than CVE-2007-3996.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04, 7.10
- Debian Linux: 3.1, 4.0
- PHP: from 4.0.0 before 4.4.8; from 5.0.0 before 5.2.4 — fixed in 4.4.8, 5.2.4
How to fix
Upgrade to a fixed version: PHP 4.4.8, 5.2.4. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/26642
- http://secunia.com/advisories/26822
- http://secunia.com/advisories/26838
- http://secunia.com/advisories/27102
- http://secunia.com/advisories/27377
- http://secunia.com/advisories/27864
- http://secunia.com/advisories/28249
- http://secunia.com/advisories/28318
- http://secunia.com/advisories/28936
- http://secunia.com/advisories/30288
- http://secweb.se/en/advisories/php-strcspn-information-leak-vulnerability/
- http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.335136
Get alerted when CVE-2007-4657 or the next vulnerability affects your stack