What’s Vulnerable › Vulnerabilities
CVE-2007-4772
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-01-09 · updated 2026-06-16
- Weakness: CWE-399
Description
The regular expression parser in TCL before 8.4.17, as used in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, and 7.4 before 7.4.19, allows context-dependent attackers to cause a denial of service (infinite loop) via a crafted regular expression.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04, 7.10
- Debian Linux: 3.1
- PostgreSQL: from 7.4 before 7.4.19; from 8.0 before 8.0.15; from 8.1 before 8.1.11; from 8.2 before 8.2.6 — fixed in 7.4.19, 8.0.15, 8.1.11, 8.2.6
- Tcl/Tk: before 8.4.17 — fixed in 8.4.17
How to fix
Upgrade to a fixed version: PostgreSQL 7.4.19, 8.0.15, 8.1.11, 8.2.6; Tcl/Tk 8.4.17. Check the vendor advisory for mitigations.
References
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01420154
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10705
- http://lists.opensuse.org/opensuse-security-announce/2008-02/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00056.html
- http://lists.opensuse.org/opensuse-security-announce/2016-03/msg00016.html
- http://rhn.redhat.com/errata/RHSA-2013-0122.html
- http://secunia.com/advisories/28359
- http://secunia.com/advisories/28376
- http://secunia.com/advisories/28437
Get alerted when CVE-2007-4772 or the next vulnerability affects your stack