What’s Vulnerable › Vulnerabilities
CVE-2007-4988
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2007-09-24 · updated 2026-06-16
- Weakness: CWE-681
Description
Sign extension error in the ReadDIBImage function in ImageMagick before 6.3.5-9 allows context-dependent attackers to execute arbitrary code via a crafted width value in an image file, which triggers an integer overflow and a heap-based buffer overflow.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04
- ImageMagick: before 6.3.5-9 — fixed in 6.3.5-9
How to fix
Upgrade to a fixed version: ImageMagick 6.3.5-9. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=186030
- http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=597
- http://secunia.com/advisories/26926
- http://secunia.com/advisories/27048
- http://secunia.com/advisories/27309
- http://secunia.com/advisories/27364
- http://secunia.com/advisories/27439
- http://secunia.com/advisories/28721
- http://secunia.com/advisories/29786
- http://secunia.com/advisories/36260
- http://security.gentoo.org/glsa/glsa-200710-27.xml
- http://studio.imagemagick.org/pipermail/magick-announce/2007-September/000037.html
Get alerted when CVE-2007-4988 or the next vulnerability affects your stack