What’s Vulnerable › Vulnerabilities
CVE-2007-5268
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-10-08 · updated 2026-06-16
Description
pngrtran.c in libpng before 1.0.29 and 1.2.x before 1.2.21 use (1) logical instead of bitwise operations and (2) incorrect comparisons, which might allow remote attackers to cause a denial of service (crash) via a crafted PNG image.
Affected products
- Canonical Ubuntu Linux: 6.06, 6.10, 7.04, 7.10
- pnggroup libpng: before 1.0.29; from 1.2.0 before 1.2.21 — fixed in 1.0.29, 1.2.21
How to fix
Upgrade to a fixed version: pnggroup libpng 1.0.29, 1.2.21. Check the vendor advisory for mitigations.
References
- http://android-developers.blogspot.com/2008/03/android-sdk-update-m5-rc15-released.html
- http://bugs.gentoo.org/show_bug.cgi?id=195261
- http://docs.info.apple.com/article.html?artnum=307562
- http://lists.apple.com/archives/security-announce/2008//May/msg00001.html
- http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html
- http://secunia.com/advisories/27093
- http://secunia.com/advisories/27284
- http://secunia.com/advisories/27405
- http://secunia.com/advisories/27529
- http://secunia.com/advisories/27629
- http://secunia.com/advisories/27746
- http://secunia.com/advisories/29420
Get alerted when CVE-2007-5268 or the next vulnerability affects your stack