What’s Vulnerable › Vulnerabilities
CVE-2007-5594
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-10-19 · updated 2026-06-16
- Weakness: CWE-352
Description
Drupal 5.x before 5.3 does not apply its Drupal Forms API protection against the user deletion form, which allows remote attackers to delete users via a cross-site request forgery (CSRF) attack.
Affected products
- Drupal: from 5.0 before 5.3 — fixed in 5.3
- Fedoraproject Fedora: 7
How to fix
Upgrade to a fixed version: Drupal 5.3. Check the vendor advisory for mitigations.
References
- http://drupal.org/node/184348
- http://secunia.com/advisories/27290
- http://secunia.com/advisories/27352
- http://www.securityfocus.com/bid/26119
- https://exchange.xforce.ibmcloud.com/vulnerabilities/37268
- https://www.redhat.com/archives/fedora-package-announce/2007-October/msg00328.html
- http://drupal.org/node/184348
- http://secunia.com/advisories/27290
- http://secunia.com/advisories/27352
- http://www.securityfocus.com/bid/26119
- https://exchange.xforce.ibmcloud.com/vulnerabilities/37268
- https://www.redhat.com/archives/fedora-package-announce/2007-October/msg00328.html
Get alerted when CVE-2007-5594 or the next vulnerability affects your stack