What’s Vulnerable › Vulnerabilities

CVE-2007-5596

Description

The core Upload module in Drupal 4.7.x before 4.7.8 and 5.x before 5.3 places the .html extension on a whitelist, which allows remote attackers to conduct cross-site scripting (XSS) attacks by uploading .html files.

Affected products

How to fix

Upgrade to a fixed version: Drupal 4.7.8, 5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2007-5596 or the next vulnerability affects your stack