What’s Vulnerable › Vulnerabilities
CVE-2007-5597
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-10-19 · updated 2026-06-16
- Weakness: CWE-264
Description
The hook_comments API in Drupal 4.7.x before 4.7.8 and 5.x before 5.3 does not pass publication status, which might allow attackers to bypass access restrictions and trigger e-mail with unpublished comments from some modules, as demonstrated by (1) Organic groups and (2) Subscriptions.
Affected products
- Drupal: from 4.7.0 before 4.7.8; from 5.0 before 5.3 — fixed in 4.7.8, 5.3
How to fix
Upgrade to a fixed version: Drupal 4.7.8, 5.3. Check the vendor advisory for mitigations.
References
- http://drupal.org/node/184354
- http://secunia.com/advisories/27292
- http://secunia.com/advisories/27352
- http://www.securityfocus.com/bid/26119
- http://www.vupen.com/english/advisories/2007/3546
- https://exchange.xforce.ibmcloud.com/vulnerabilities/37296
- https://www.redhat.com/archives/fedora-package-announce/2007-October/msg00328.html
- http://drupal.org/node/184354
- http://secunia.com/advisories/27292
- http://secunia.com/advisories/27352
- http://www.securityfocus.com/bid/26119
- http://www.vupen.com/english/advisories/2007/3546
Get alerted when CVE-2007-5597 or the next vulnerability affects your stack