What’s Vulnerable › Vulnerabilities
CVE-2007-5598
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-10-19 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Weblinks for Drupal 4.7.x before 4.7.x-1.0 and 5.x before 5.x-1.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected products
- Web Links Project Web Links: from 4.7.x before 4.7.x-1.0; from 5.x before 5.x-1.8 — fixed in 4.7.x-1.0, 5.x-1.8
How to fix
Upgrade to a fixed version: Web Links Project Web Links 4.7.x-1.0, 5.x-1.8. Check the vendor advisory for mitigations.
References
- http://drupal.org/node/184323
- http://osvdb.org/37904
- http://secunia.com/advisories/27289
- http://www.securityfocus.com/bid/26125
- https://exchange.xforce.ibmcloud.com/vulnerabilities/37278
- http://drupal.org/node/184323
- http://osvdb.org/37904
- http://secunia.com/advisories/27289
- http://www.securityfocus.com/bid/26125
- https://exchange.xforce.ibmcloud.com/vulnerabilities/37278
Get alerted when CVE-2007-5598 or the next vulnerability affects your stack