What’s Vulnerable › Vulnerabilities
CVE-2007-5659: Adobe Acrobat and Reader Buffer Overflow Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-06-08
- EPSS: 87.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-02-12 · updated 2026-06-16
- Weakness: CWE-120
Description
Multiple buffer overflows in Adobe Reader and Acrobat 8.1.1 and earlier allow remote attackers to execute arbitrary code via a PDF file with long arguments to unspecified JavaScript methods. NOTE: this issue might be subsumed by CVE-2008-0655.
Affected products
- Adobe Acrobat for Edge: before 8.1.2 — fixed in 8.1.2
- Adobe Acrobat Reader: before 8.1.2 — fixed in 8.1.2
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 8.1.2; Adobe Acrobat Reader 8.1.2. Check the vendor advisory for mitigations.
References
- http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=657
- http://secunia.com/advisories/29065
- http://secunia.com/advisories/29205
- http://secunia.com/advisories/30840
- http://security.gentoo.org/glsa/glsa-200803-01.xml
- http://sunsolve.sun.com/search/document.do?assetkey=1-26-239286-1
- http://www.adobe.com/support/security/advisories/apsa08-01.html
- http://www.adobe.com/support/security/bulletins/apsb08-13.html
- http://www.kb.cert.org/vuls/id/666281
- http://www.redhat.com/support/errata/RHSA-2008-0144.html
- http://www.us-cert.gov/cas/techalerts/TA08-043A.html
- http://www.vupen.com/english/advisories/2008/1966/references
Get alerted when CVE-2007-5659 or the next vulnerability affects your stack