What’s Vulnerable › Vulnerabilities
CVE-2007-6170
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-11-30 · updated 2026-06-16
- Weakness: CWE-89
Description
SQL injection vulnerability in the Call Detail Record Postgres logging engine (cdr_pgsql) in Asterisk 1.4.x before 1.4.15, 1.2.x before 1.2.25, B.x before B.2.3.4, and C.x before C.1.0-beta6 allows remote authenticated users to execute arbitrary SQL commands via (1) ANI and (2) DNIS arguments.
Affected products
- Debian Linux: 3.1, 4.0
- Digium Asterisk: from 1.2.0 before 1.2.25; from 1.4.0 before 1.4.15; from b.2.3.0 before b.2.3.4; c.1.0-beta1, c.1.0-beta2, c.1.0-beta3, c.1.0-beta4, c.1.0-beta5 — fixed in 1.2.25, 1.4.15, b.2.3.4
How to fix
Upgrade to a fixed version: Digium Asterisk 1.2.25, 1.4.15, b.2.3.4. Check the vendor advisory for mitigations.
References
- http://downloads.digium.com/pub/security/AST-2007-026.html
- http://lists.opensuse.org/opensuse-security-announce/2008-03/msg00001.html
- http://secunia.com/advisories/27827
- http://secunia.com/advisories/27892
- http://secunia.com/advisories/29242
- http://secunia.com/advisories/29782
- http://security.gentoo.org/glsa/glsa-200804-13.xml
- http://securitytracker.com/id?1019020
- http://www.debian.org/security/2007/dsa-1417
- http://www.securityfocus.com/archive/1/484388/100/0/threaded
- http://www.securityfocus.com/bid/26647
- http://www.vupen.com/english/advisories/2007/4056
Get alerted when CVE-2007-6170 or the next vulnerability affects your stack