What’s Vulnerable › Vulnerabilities
CVE-2007-6171
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2007-11-30 · updated 2026-06-16
- Weakness: CWE-89
Description
SQL injection vulnerability in the Postgres Realtime Engine (res_config_pgsql) in Asterisk 1.4.x before 1.4.15 and C.x before C.1.0-beta6 allows remote attackers to execute arbitrary SQL commands via unknown vectors.
Affected products
- Digium Asterisk: from 1.4.0 before 1.4.15; c.1.0-beta1, c.1.0-beta2, c.1.0-beta3, c.1.0-beta4, c.1.0-beta5 — fixed in 1.4.15
How to fix
Upgrade to a fixed version: Digium Asterisk 1.4.15. Check the vendor advisory for mitigations.
References
- http://downloads.digium.com/pub/security/AST-2007-025.html
- http://osvdb.org/38933
- http://secunia.com/advisories/27873
- http://securitytracker.com/id?1019021
- http://www.securityfocus.com/archive/1/484387/100/0/threaded
- http://www.securityfocus.com/bid/26645
- http://www.vupen.com/english/advisories/2007/4055
- https://exchange.xforce.ibmcloud.com/vulnerabilities/38766
- http://downloads.digium.com/pub/security/AST-2007-025.html
- http://osvdb.org/38933
- http://secunia.com/advisories/27873
- http://securitytracker.com/id?1019021
Get alerted when CVE-2007-6171 or the next vulnerability affects your stack