What’s Vulnerable › Vulnerabilities

CVE-2007-6601

Description

The DBLink module in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, 7.4 before 7.4.19, and 7.3 before 7.3.21, when local trust or ident authentication is used, allows remote attackers to gain privileges via unspecified vectors. NOTE: this issue exists because of an incomplete fix for CVE-2007-3278.

Affected products

How to fix

Upgrade to a fixed version: PostgreSQL 7.3.21, 7.4.19, 8.0.15, 8.1.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2007-6601 or the next vulnerability affects your stack