What’s Vulnerable › Vulnerabilities

CVE-2008-0387

Description

Integer overflow in Firebird SQL 1.0.3 and earlier, 1.5.x before 1.5.6, 2.0.x before 2.0.4, and 2.1.x before 2.1.0 RC1 might allow remote attackers to execute arbitrary code via crafted (1) op_receive, (2) op_start, (3) op_start_and_receive, (4) op_send, (5) op_start_and_send, and (6) op_start_send_and_receive XDR requests, which triggers memory corruption.

Affected products

How to fix

Upgrade to a fixed version: FirebirdSQL firebird 1.5.6, 2.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-0387 or the next vulnerability affects your stack