What’s Vulnerable › Vulnerabilities

CVE-2008-2079

Description

MySQL 4.1.x before 4.1.24, 5.0.x before 5.0.60, 5.1.x before 5.1.24, and 6.0.x before 6.0.5 allows local users to bypass certain privilege checks by calling CREATE TABLE on a MyISAM table with modified (1) DATA DIRECTORY or (2) INDEX DIRECTORY arguments that are within the MySQL home data directory, which can point to tables that are created in the future.

Affected products

How to fix

Upgrade to a fixed version: Mysql 4.1.24, 5.0.60, 5.1.24; MySQL Server 6.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-2079 or the next vulnerability affects your stack