What’s Vulnerable › Vulnerabilities
CVE-2008-2108
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-05-07 · updated 2026-06-16
- Weakness: CWE-331
Description
The GENERATE_SEED macro in PHP 4.x before 4.4.8 and 5.x before 5.2.5, when running on 64-bit systems, performs a multiplication that generates a portion of zero bits during conversion due to insufficient precision, which produces 24 bits of entropy and simplifies brute force attacks against protection mechanisms that use the rand and mt_rand functions.
Affected products
- Canonical Ubuntu Linux: 6.06, 7.04, 7.10, 8.04
- Debian Linux: 4.0
- Fedoraproject Fedora: 8, 9
- PHP: from 4.0.0 before 4.4.8; from 5.0.0 before 5.2.5 — fixed in 4.4.8, 5.2.5
How to fix
Upgrade to a fixed version: PHP 4.4.8, 5.2.5. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/fulldisclosure/2008-05/0103.html
- http://secunia.com/advisories/30757
- http://secunia.com/advisories/30828
- http://secunia.com/advisories/31119
- http://secunia.com/advisories/31124
- http://secunia.com/advisories/31200
- http://secunia.com/advisories/32746
- http://secunia.com/advisories/35003
- http://security.gentoo.org/glsa/glsa-200811-05.xml
- http://securityreason.com/securityalert/3859
- http://www.debian.org/security/2009/dsa-1789
- http://www.mandriva.com/security/advisories?name=MDVSA-2008:125
Get alerted when CVE-2008-2108 or the next vulnerability affects your stack