What’s Vulnerable › Vulnerabilities
CVE-2008-2271
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-05-16 · updated 2026-06-16
- Weakness: CWE-269
Description
The Site Documentation Drupal module 5.x before 5.x-1.8 and 6.x before 6.x-1.1 allows remote authenticated users to gain privileges of other users by leveraging the "access content" permission to list tables and obtain session IDs from the database.
Affected products
- Site Documentation Project Site Documentation: from 5.x-1.0 before 5.x-1.8; from 6.x-1.0 before 6.x-1.1 — fixed in 5.x-1.8, 6.x-1.1
How to fix
Upgrade to a fixed version: Site Documentation Project Site Documentation 5.x-1.8, 6.x-1.1. Check the vendor advisory for mitigations.
References
- http://drupal.org/node/258547
- http://secunia.com/advisories/30257
- http://www.securityfocus.com/bid/29242
- http://www.vupen.com/english/advisories/2008/1541/references
- https://exchange.xforce.ibmcloud.com/vulnerabilities/42453
- http://drupal.org/node/258547
- http://secunia.com/advisories/30257
- http://www.securityfocus.com/bid/29242
- http://www.vupen.com/english/advisories/2008/1541/references
- https://exchange.xforce.ibmcloud.com/vulnerabilities/42453
Get alerted when CVE-2008-2271 or the next vulnerability affects your stack